Engine Run

First engine run on 6-10-14.  All looked good except for the T-30 digital tach.  I will have to check the set up and make sure it is for 2 pulses per rev. and maybe add some software filtering.  I the Insight engine monitor showed good even CHTs and EGTs.  Alternator was charging and the warning lite went out like it should.  Checked both the Pmag and regular mag and both working fine.  Pmag continued to funtion with the RPM above 900 and circuit breaker pulled as it should with its internal power  alternator.  Oil pressure was about 60 PSI shown on the gauge.  Fuel Pressure was good on both the mechanical and electeric pumps.  The Ellison Throttle Body worked well out of the box.  I will go through thier setup proceedures on the next engine run.  My battery is over 10 years old and crapped out, so I ordered a new Odyssey battery with boo coo starting capacity! 

 Click on Engine Start for Video

Engine Start 6-10-14

 

 

Prop Install

Mag timed and engine re-installed

Prop Install 2

 Prop installed ready for first engine run

Prop Install 1

Mag Timing

Pulling Engine for Left Mag Timing

 

Engine Pull 1

Engine pull 2

Left Mag

Timing way off, so left mag needed to be pulled, which require the engine be pulled back.  Tight fit!

 

 

Prop Install

 

Beautiful Catto Prop

 

 

Catto Prop

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

A Big 3 Blade Fan!

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Prop Data Plate

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Saber SAE-2 8 inch extention with a 7 inch diameter plate

 

Oil Cooler Installation

Oil Cooler install

Oil Cooler exhaust duct

Oil Cooler complete

Bottom Cowl

Bumpout on lower cowl to fit airbox

Lower Cowl Mod for Airbox

Engine

 

Pmag electronic ignition

Left side Mag

Airbox with K&N filter

 Airbox with K&N filter

Exhaust System

 Exhaust with heat muff

 

Rt side exhaust clamp